Opened 12 years ago

Closed 12 years ago

#6374 closed defect (fixed)

[with patch, positive review] Fix race condition in sage build process

Reported by: craigcitro Owned by: tbd
Priority: blocker Milestone: sage-4.1.1
Component: build Keywords:
Cc: ncalexan, GeorgSWeber Merged in: Sage 4.1.1.alpha1
Authors: Craig Citro Reviewers: Georg S. Weber
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

So on #6234, there was a second patch to fix a race condition that Nick saw during the 4.0.2 release cycle. Someone else just ran into this, and I noticed that the second patch from that ticket somehow didn't make it into Sage. (Oops.)

I'm attaching the patch here, with the same filename -- see #6234 (at the bottom) for an example of the bad behavior and an explanation for the fix. It's already been reviewed at least once, but a second review wouldn't hurt. ;)

Attachments (1)

trac-6234-pt2.patch (1.9 KB) - added by craigcitro 12 years ago.

Download all attachments as: .zip

Change History (4)

Changed 12 years ago by craigcitro

comment:1 Changed 12 years ago by GeorgSWeber

  • Cc GeorgSWeber added

At least twice, I ran into the failure (hopefully) fixed by this ticket. I already volunteered to review it (in a note on sage-release), but if somebody else is faster, OK.

comment:2 Changed 12 years ago by GeorgSWeber

  • Reviewers set to Georg S. Weber
  • Summary changed from [with patch, needs review] Fix race condition in sage build process to [with patch, positive review] Fix race condition in sage build process

Works fine for/with Sage-4.1.1.alpha0. It's hard to "prove" that a certain sporadic failures has been fixed, but the patch at least doesn't hurt. And it is plausible that it does help indeed.

comment:3 Changed 12 years ago by mvngu

  • Merged in set to Sage 4.1.1.alpha1
  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.