Opened 12 years ago

Closed 6 years ago

Last modified 6 years ago

#6311 closed defect (duplicate)

optional doctest failure -- supersingular_j

Reported by: was Owned by: tbd
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: number theory Keywords:
Cc: Merged in:
Authors: Reviewers: Jeroen Demeyer
Report Upstream: N/A Work issues:
Branch: u/jdemeyer/optional_doctest_failure____supersingular_j (Commits, GitHub, GitLab) Commit: b20b2b0a893f410b8bc1550b940cdffa34b0117e
Dependencies: Stopgaps:

Status badges

Description (last modified by chapoton)

sage -t -long --optional devel/sage/sage/modular/ssmod/ssmod.py
**********************************************************************
File "/scratch/wstein/build/sage-4.0.2.alpha3/devel/sage-main/sage/modular/ssmod/ssmod.py", line 571:
    sage: supersingular_j(GF(15073^2,'a'))  # optional -- requires database
Expected:
    10630*a + 6033
Got:
    4443*a + 13964
**********************************************************************
1 items had failures:
   1 of   5 in __main__.example_5
***Test Failed*** 1 failures.
For whitespace errors, see the file /home/wstein/build/sage-4.0.2.alpha3/tmp/.doctest_ssmod.py
 [20.9 s]

Change History (14)

comment:1 Changed 8 years ago by jdemeyer

  • Milestone changed from sage-5.11 to sage-5.12

comment:2 Changed 8 years ago by chapoton

  • Report Upstream set to N/A

This failure is still there in 5.12.beta4.

The results are related by the action of the Frobenius involution. So the problem is not too bad.

comment:3 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.1 to sage-6.2

comment:4 Changed 7 years ago by chapoton

Now the doctest is

sage -t --optional=all src/sage/modular/ssmod/ssmod.py

comment:5 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.2 to sage-6.3

comment:6 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.3 to sage-6.4

comment:7 Changed 6 years ago by chapoton

  • Status changed from new to needs_info

what should we do here ? just change the doctest result ?

comment:8 Changed 6 years ago by jdemeyer

  • Branch set to u/jdemeyer/optional_doctest_failure____supersingular_j

comment:9 Changed 6 years ago by jdemeyer

  • Authors set to Jeroen Demeyer
  • Commit set to 009159d8fd9362a15b0c64fb9896f8f786a7f333
  • Component changed from packages: optional to doctest framework
  • Status changed from needs_info to needs_review

New commits:

009159dFix optional doctest

comment:10 Changed 6 years ago by jdemeyer

Remove # optional in #18049.

comment:11 Changed 6 years ago by git

  • Commit changed from 009159d8fd9362a15b0c64fb9896f8f786a7f333 to b20b2b0a893f410b8bc1550b940cdffa34b0117e

Branch pushed to git repo; I updated commit sha1. New commits:

b20b2b0Use PARI to compute class and modular polynomials

comment:12 Changed 6 years ago by jdemeyer

  • Authors Jeroen Demeyer deleted
  • Component changed from doctest framework to number theory
  • Milestone changed from sage-6.4 to sage-duplicate/invalid/wontfix
  • Reviewers set to Jeroen Demeyer
  • Status changed from needs_review to positive_review

I think we can just close this as "duplicate" of #18049.

comment:13 Changed 6 years ago by vbraun

  • Resolution set to duplicate
  • Status changed from positive_review to closed

comment:14 Changed 6 years ago by chapoton

  • Description modified (diff)
Note: See TracTickets for help on using tickets.