Opened 12 years ago

Closed 8 years ago

Last modified 8 years ago

#6247 closed defect (duplicate)

sage -optional tries to write to SAGE_ROOT

Reported by: burcin Owned by: cwitty
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: misc Keywords:
Cc: Merged in:
Authors: Reviewers: Jeroen Demeyer
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

Reported by somos on #sage-devel on IRC

<somos> when I do 'sage -optional' it tried to make a temp file in SAGE_ROOT
...
<somos> This is ok if you are running as root user.
...
<mvngu> From the help:
<mvngu> -optional     -- list all optional packages that can be downloaded
<somos> Anyway, the problem is the temp file in SAGE_ROOT.
<somos> It should be in /tmp instead.
<mvngu> Can you explain why it should be in /tmp ?
<somos> Becuase SAGE_ROOT requires root permissions.
...
<somos> So, my suggestion is to avoid the temp file. #1
<somos> If a temp file is needed, I suggest TMP or TMPDIR instead.

Change History (5)

comment:1 Changed 8 years ago by jdemeyer

  • Milestone changed from sage-5.11 to sage-5.12

comment:2 Changed 8 years ago by jdemeyer

  • Milestone changed from sage-5.12 to sage-duplicate/invalid/wontfix
  • Report Upstream set to N/A
  • Reviewers set to Jeroen Demeyer
  • Status changed from new to needs_review

Duplicate of #12018.

comment:3 Changed 8 years ago by jdemeyer

  • Status changed from needs_review to positive_review

comment:4 Changed 8 years ago by jdemeyer

  • Resolution set to worksforme
  • Status changed from positive_review to closed

comment:5 Changed 8 years ago by jdemeyer

  • Resolution changed from worksforme to duplicate
Note: See TracTickets for help on using tickets.