Opened 12 years ago

Closed 12 years ago

#6242 closed defect (duplicate)

*long* birds_other.rst doctest fails with mysterious error repeatedly on OS X

Reported by: was Owned by: was
Priority: critical Milestone: sage-4.1
Component: number theory Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

wstein@bsd:~/build/sage-4.0.1$ ./sage -t -long "devel/sage/doc/en/bordeaux_2008/birds_other.rst"
sage -t -long "devel/sage/doc/en/bordeaux_2008/birds_other.rst"
A mysterious error (perhaps a memory error?) occurred, which may have crashed doctest.
         [44.5 s]
exit code: 768

----------------------------------------------------------------------
The following tests failed:


        sage -t -long "devel/sage/doc/en/bordeaux_2008/birds_other.rst"

wstein@bsd:~/build/sage-4.0.1$ ./sage -t  "devel/sage/doc/en/bordeaux_2008/birds_other.rst"
sage -t  "devel/sage/doc/en/bordeaux_2008/birds_other.rst"  
         [39.5 s]
 
----------------------------------------------------------------------
All tests passed!
Total time for all tests: 39.5 seconds
wstein@bsd:~/build/sage-4.0.1$ 

Change History (3)

comment:1 Changed 12 years ago by was

The failure does not happen in --verbose mode. :-(

comment:2 Changed 12 years ago by was

  • Priority changed from blocker to critical

This happens very sporadically, and is triggered by the parallel bernoulli number code by David Harvey.

comment:3 Changed 12 years ago by craigcitro

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #6304, where David Harvey has made some more specific comments about what's causing this.

Note: See TracTickets for help on using tickets.