Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#6090 closed defect (duplicate)

plot(x^2, (x, -2, 2), fill=2) does not match documentation

Reported by: jason Owned by: was
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: graphics Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

According to the docs, if fill is a number c, then: "a number c: Fill the area between the function and the horizontal line y = c."

However, the above plot just fills to the x-axis. My guess is that it is because bool(2)==True, so plot thinks we have fill=True?

Change History (7)

comment:1 follow-up: Changed 12 years ago by whuss

This is a duplicate of #5438.

comment:2 in reply to: ↑ 1 ; follow-up: Changed 12 years ago by mabshoff

Replying to whuss:

This is a duplicate of #5438.

Hmm, given that this went into 3.4.2 I wonder why Jason did hit this problem?

Cheers,

Michael

comment:3 Changed 12 years ago by mabshoff

  • Summary changed from plot(x^2, (x, -2, 2), fill=2) does not match documentation to [probably dupe] plot(x^2, (x, -2, 2), fill=2) does not match documentation

Jason,

I am marking this a potential dupe in the summary so we won't forget to close it assuming you can confirm it as one.

Cheers,

Michael

comment:4 in reply to: ↑ 2 ; follow-up: Changed 12 years ago by whuss

Replying to mabshoff:

Replying to whuss:

This is a duplicate of #5438.

Hmm, given that this went into 3.4.2 I wonder why Jason did hit this problem?

#5438 says it went into 4.0.alpha0 not 3.4.2.

Cheers,
Wilfried

comment:5 in reply to: ↑ 4 Changed 12 years ago by mabshoff

  • Milestone changed from sage-4.0.1 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from new to closed

Replying to whuss:

#5438 says it went into 4.0.alpha0 not 3.4.2.

Oops, I must have looked at some permutation of "5438" then. Sorry for the screwup.

Cheers,
Wilfried

Closed as dupe. Jason: If you disagree let us know.

Cheers,

Michael

comment:6 Changed 12 years ago by jason

Okay, I just tested it in 4.0, and it works great. Sorry; it seems that I should have caught the other ticket in a search. I'm not sure why I didn't. Thanks for the prompt response!

comment:7 Changed 12 years ago by jason

  • Summary changed from [probably dupe] plot(x^2, (x, -2, 2), fill=2) does not match documentation to plot(x^2, (x, -2, 2), fill=2) does not match documentation
Note: See TracTickets for help on using tickets.