Opened 12 years ago

Closed 9 years ago

#6058 closed defect (duplicate)

[with patch, needs comments] Add basic statistics functionality at the top level

Reported by: mhampton Owned by: mhampton
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: statistics Keywords:
Cc: Merged in:
Authors: Reviewers: Karl-Dieter Crisman
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by jdemeyer)

Sage should provide basic statistics functionality at the top level. These functions might use scipy.stats or R or a new native implementation. For graphics in particular we should probably bypass R.

This ticket will merely start this process with one patch, but will not completely address the needed functionality.

Duplicate of #7197

Attachments (1)

trac_6058_basic_stats1.patch (1.6 KB) - added by mhampton 12 years ago.
A baby step towards top-level statistics

Download all attachments as: .zip

Change History (7)

Changed 12 years ago by mhampton

A baby step towards top-level statistics

comment:1 Changed 12 years ago by mhampton

Comments are welcome on this very initial effort.

comment:2 Changed 12 years ago by mhampton

  • Summary changed from Add basic statistics functionality at the top level to [with patch, needs comments] Add basic statistics functionality at the top level

comment:3 Changed 12 years ago by mhampton

  • Component changed from numerical to statistics
  • Owner changed from jkantor to mhampton

comment:4 Changed 12 years ago by craigcitro

Two quick comments:

  • With the mean function, dividing by len(a_list) is really dangerous -- for instance, if you give the function a collection of Python ints, then it will do Python int division -- so 3/2 = 1, etc. Bad news.
  • Do we want to use the name std for standard deviation? Since the other systems (e.g. R) use that, we should have it available, but I would also like to have the full standard_deviation available (especially since we have variance as opposed to just var, for obvious reasons).

comment:5 Changed 9 years ago by kcrisman

  • Milestone changed from sage-5.1 to sage-duplicate/invalid/wontfix
  • Report Upstream set to N/A
  • Reviewers set to Karl-Dieter Crisman
  • Status changed from needs_work to positive_review

This apparently was done at around the same time as this was posted by #7197, and no one noticed. Sorry, Marshall :( but on the plus side we have had this since Sage 4.3 :)

To release manager - this is invalid/dup.

comment:6 Changed 9 years ago by jdemeyer

  • Description modified (diff)
  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.