Opened 12 years ago

Closed 12 years ago

#6039 closed defect (fixed)

[with patch, positive review] Change name of pari's sum function when imported

Reported by: craigcitro Owned by: craigcitro
Priority: major Milestone: sage-4.0
Component: interfaces Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

When we include Pari's sum function via libs/pari/decl.pxi, it takes precedence over the default Python one. This causes some rather confusing compiler errors -- see, e.g., this thread:

http://groups.google.com/group/sage-devel/browse_thread/thread/68a7bd7e99ef22e6#

The attached patch uses string replace magic to rename it to pari_sum.

Attachments (1)

trac-6039.patch (843 bytes) - added by craigcitro 12 years ago.

Download all attachments as: .zip

Change History (3)

Changed 12 years ago by craigcitro

comment:1 Changed 12 years ago by mabshoff

  • Summary changed from [with patch, needs review] Change name of pari's sum function when imported to [with patch, positive review] Change name of pari's sum function when imported

It is never a good idea to touch sage/libs/pari/decl.pxi :). Positive review.

Cheers,

Michael

comment:2 Changed 12 years ago by mabshoff

  • Resolution set to fixed
  • Status changed from new to closed

Merged in Sage 4.0.alpha0.

Cheers,

Michael

Note: See TracTickets for help on using tickets.