Opened 11 years ago

Closed 11 years ago

Last modified 4 years ago

#6025 closed defect (fixed)

[with patch, positive review] Sage 3.4.2: doctest failure in sage/libs/pari/gen.pyx on 64 bit OSX

Reported by: mabshoff Owned by: mabshoff
Priority: blocker Milestone: sage-4.0
Component: porting Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description (last modified by chapoton)

sage -t -long "devel/sage/sage/libs/pari/gen.pyx"           
**********************************************************************
File "/Users/mabshoff/sage-3.4.2-64/devel/sage/sage/libs/pari/gen.pyx", line 8945:
    sage: pari.finitefield_init(7,2)
Exception raised:
    Traceback (most recent call last):
      File "/Users/mabshoff/sage-3.4.2-64/local/bin/ncadoctest.py", line 1231, in run_one_test
        self.run_one_example(test, example, filename, compileflags)
      File "/Users/mabshoff/sage-3.4.2-64/local/bin/sagedoctest.py", line 38, in run_one_example
        OrigDocTestRunner.run_one_example(self, test, example, filename, compileflags)
      File "/Users/mabshoff/sage-3.4.2-64/local/bin/ncadoctest.py", line 1172, in run_one_example
        compileflags, 1) in test.globs
      File "<doctest __main__.example_291[4]>", line 1, in <module>
        pari.finitefield_init(Integer(7),Integer(2))###line 8945:
    sage: pari.finitefield_init(7,2)
    RuntimeError
**********************************************************************
File "/Users/mabshoff/sage-3.4.2-64/devel/sage/sage/libs/pari/gen.pyx", line 8950:
    sage: pari.finitefield_init(2,3)
Exception raised:
    Traceback (most recent call last):
      File "/Users/mabshoff/sage-3.4.2-64/local/bin/ncadoctest.py", line 1231, in run_one_test
        self.run_one_example(test, example, filename, compileflags)
      File "/Users/mabshoff/sage-3.4.2-64/local/bin/sagedoctest.py", line 38, in run_one_example
        OrigDocTestRunner.run_one_example(self, test, example, filename, compileflags)
      File "/Users/mabshoff/sage-3.4.2-64/local/bin/ncadoctest.py", line 1172, in run_one_example
        compileflags, 1) in test.globs
      File "<doctest __main__.example_291[5]>", line 1, in <module>
        pari.finitefield_init(Integer(2),Integer(3))###line 8950:
    sage: pari.finitefield_init(2,3)
    RuntimeError
**********************************************************************
1 items had failures:
   2 of   6 in __main__.example_291
***Test Failed*** 2 failures.
For whitespace errors, see the file /Users/mabshoff/sage-3.4.2-64/tmp/.doctest_gen.py
 [19.0 s]

Attachments (1)

trac-6025.patch (2.7 KB) - added by craigcitro 11 years ago.

Download all attachments as: .zip

Change History (5)

Changed 11 years ago by craigcitro

comment:1 Changed 11 years ago by craigcitro

  • Summary changed from Sage 3.4.2: doctest failure in sage/libs/pari/gen.pyx on 64 bit OSX to [with patch, needs review] Sage 3.4.2: doctest failure in sage/libs/pari/gen.pyx on 64 bit OSX

As William pointed out on the mailing list, this code isn't used anywhere -- so we're just killing the function. The problem is that on 64 bit OSX, a value getting returned loses its top 4 bytes. This is clearly weird, but since this pari function is known to be buggy, we'll just not use it for now and cross our fingers.

comment:2 Changed 11 years ago by mabshoff

  • Summary changed from [with patch, needs review] Sage 3.4.2: doctest failure in sage/libs/pari/gen.pyx on 64 bit OSX to [with patch, positive review] Sage 3.4.2: doctest failure in sage/libs/pari/gen.pyx on 64 bit OSX

Ok, good to go.

Cheers,

Michael

comment:3 Changed 11 years ago by mabshoff

  • Resolution set to fixed
  • Status changed from new to closed

Merged in Sage 4.0.alpha0.

Cheers,

Michael

comment:4 Changed 4 years ago by chapoton

  • Description modified (diff)
  • Report Upstream set to N/A
Note: See TracTickets for help on using tickets.