Opened 12 years ago

Closed 12 years ago

#6002 closed defect (duplicate)

parametric_plot3d appears not to give the correct axes values

Reported by: wcauchois Owned by: was
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: graphics Keywords:
Cc: mvngu Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

Alden Walker describes the bug in a sage-support thread:

When I run:

parametric_plot( (cos(t), sqrt(2)*sin(t)) , (t,0,2*pi))

I get a nice 2d parametric plot, with the top of the ellipse clearly hitting close to 1.5 on the y-axis. When I run:

parametric_plot3d( (cos(t), 1 , sqrt(2)*sin(t)), (t,0,2*pi))

The top of the ellipse really looks like it's at z=1, and the whole thing looks a lot like a circle.

Even though the bounding box is reported to be ((-1.0, 1.0, -1.41293...), (1.0, 1.0, 1.41293...)), jmol labels the axes as (-1, 1), (-1, 1), and (0, 2).

If we construct the curve manually:

var('t')
from sage.plot.plot import var_and_list_of_values
_, vals = var_and_list_of_values((0, 2*pi), 75)
w = []
for t in vals:
    w.append(map(float, (cos(t), 1, sqrt(2)*sin(t))))

Then notice that while line3d(w) is still incorrect, line3d(w[0:43]) looks correct -- that is, plotting only part of the graph eliminates the error somehow. Quite curious!

Change History (2)

comment:1 Changed 12 years ago by jason

  • Cc mvngu added

#6930 fixes this.

comment:2 Changed 12 years ago by mvngu

  • Milestone changed from sage-4.1.2 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from new to closed

Close as duplicate of #6930.

Note: See TracTickets for help on using tickets.