Opened 14 years ago

Closed 12 years ago

#597 closed defect (duplicate)

Why are single-argument arithmetic functions in the coercion model?

Reported by: robertwb Owned by: somebody
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: basic arithmetic Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

Is there any advantage to having _neg_c/_neg_/_neg_c_imple as opposed to overriding neg?

Change History (4)

comment:1 Changed 14 years ago by mabshoff

  • Milestone set to Sage-2.10

comment:2 Changed 13 years ago by mabshoff

  • Milestone changed from sage-2.10 to sage-2.9

comment:3 Changed 12 years ago by robertwb

Now that cpdef methods are used, one can just implement __neg__ and __inverse__, we don't need this infrastructure for unary operations (and it slows them down).

We should do a full search of the source.

comment:4 Changed 12 years ago by mhansen

  • Milestone changed from sage-3.2.1 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from new to closed

This is a now duplicate of #2072, which is more recent.

Note: See TracTickets for help on using tickets.