Opened 12 years ago

Closed 12 years ago

#5937 closed defect (invalid)

graph theory -- showing the result of a database query with_picture=True is totally broken

Reported by: was Owned by: rlm
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: graph theory Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

Here is *yet another* example of non-tested code being totally broken. Try this in the notebook.

Q = GraphQuery(display_cols=['graph6','num_vertices','degree_sequence'],
   num_edges=['<=',5],min_degree=1)

Q.show(with_picture=True)

this silently outputs absolutely nothing.

The doctests don't test this -- they only test that this fails (with a message) on the command line.

Shorterm fix: completely remove this option from the documentation and code.

Lonterm fix: actually track down and fix the bug -- this would be nice, since I know the output looks good (I've seen Emily demo it).

Change History (3)

comment:1 Changed 12 years ago by ekirkman

I am unable to duplicate this bug. I'm using a clean branch of 4.0alpha0. Can someone else give this a try?

comment:2 Changed 12 years ago by rlm

I have the same result. Everything looks fine for me.

William -- Could you try reproducing this? If you can, can we get what machine/version it is on?

comment:3 Changed 12 years ago by rlm

  • Milestone changed from sage-4.1.1 to sage-duplicate/invalid/wontfix
  • Resolution set to invalid
  • Status changed from new to closed

This has been open for 8 weeks with zero comment, so I'm assuming this is no longer valid.

Note: See TracTickets for help on using tickets.