Opened 14 years ago

Closed 8 years ago

#589 closed enhancement (duplicate)

improve doctesting of sage-sage script

Reported by: was Owned by: was
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: packages: standard Keywords:
Cc: Merged in:
Authors: Reviewers: Jeroen Demeyer
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

On 9/4/07, Jonathan Bober <jwbober@gmail.com> wrote:
> My memory could be wrong, but I feel that this exact problem has
> occurred before. (The problem of running scripts on the command line not
> working -- not necessarily the exact same underlying cause for the
> problem.)
>
> This kind of basic functionality should probably be tested somewhere
> automatically. Maybe a doctect with a line like
>
> sage: os.system('.\sage something_or_other.sage')
>
> might work. Or maybe this would need to be somehow tested outside the
> doctest framework. I don't know. Just a thought.

True.

Implement some doctests like that  and post a patch to trac. :-)

Change History (4)

comment:1 Changed 13 years ago by mabshoff

  • Milestone changed from sage-2.9.1 to sage-2.9

comment:2 Changed 11 years ago by kcrisman

  • Report Upstream set to N/A

This seems not too hard. In what file would such doctests live?

comment:3 Changed 9 years ago by kcrisman

Note that this is now $SAGE_ROOT/spkg/bin/sage. If this ticket is still valid.

comment:4 Changed 8 years ago by jdemeyer

  • Milestone changed from sage-5.7 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Reviewers set to Jeroen Demeyer
  • Status changed from new to closed

Duplicate of #10300 + #10326 + #12249 + #9191.

Note: See TracTickets for help on using tickets.