Opened 12 years ago

Closed 12 years ago

#5831 closed defect (duplicate)

Reducible root system fixes

Reported by: bump Owned by: bump
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: combinatorics Keywords:
Cc: sage-combinat Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by bump)

The methods simple_roots(), fundamental_weights() and simple_coroots() for the ambient space of a root system are supposed to return a family. This was never correctly implemented for the reducible types, and the patch corrects this.

There are also some changes in weyl_characters.py, where it was assumed that the root system was irreducible in a few places. The patch corrects this.

The patch trac_5831.patch supercedes reducible.patch. It goes on top of trac_5751-rebased-3.4.1.rc4.patch.

Attachments (2)

reducible.patch (6.2 KB) - added by bump 12 years ago.
fixes for reducible root systems
trac_5831.patch (7.0 KB) - added by bump 12 years ago.

Download all attachments as: .zip

Change History (11)

Changed 12 years ago by bump

fixes for reducible root systems

comment:1 Changed 12 years ago by bump

  • Status changed from new to assigned

comment:2 Changed 12 years ago by bump

  • Description modified (diff)
  • Summary changed from [with patch, not ready for review] reducible root system fixes to [with patch, needs review] reducible root system fixes

comment:3 Changed 12 years ago by nthiery

Sounds good to me. Is it needed to implement simple_roots? I would have expected the default implementation for ambient spaces (as coroots associated to the simple roots) to work.

comment:4 follow-up: Changed 12 years ago by bump

Replying to the last message, I think it is necessary to implement simple_roots (and also simple_coroots and fundamental_weights).

Nicolas requested a doctest. See:

http://groups.google.com/group/sage-combinat-devel/msg/4004c4a8471f3cfa?hl=en&pli=1

I did this. I put the new doctest in type_reducible.py.

comment:5 in reply to: ↑ 4 Changed 12 years ago by nthiery

Replying to the last message, I think it is necessary to implement simple_roots (and also simple_coroots and fundamental_weights).

Oops, sorry for the confusion. I was wondering wether it was necessary to implement the simple *coroots*. For the roots, definitely yes.

Nicolas requested a doctest. See: http://groups.google.com/group/sage-combinat-devel/msg/4004c4a8471f3cfa?hl=en&pli=1 I did this. I put the new doctest in type_reducible.py.

Thanks!

Changed 12 years ago by bump

comment:6 Changed 12 years ago by bump

Revised: WeylCharacterRing? derives the name of its Cartan Type from its Cartan Type's __repr__ method.

comment:7 Changed 12 years ago by bump

This ticket may be closed if trac_5794-revised.patch is merged. See #5794.

comment:8 Changed 12 years ago by nthiery

  • Summary changed from [with patch, needs review] reducible root system fixes to Reducible root system fixes

comment:9 Changed 12 years ago by mvngu

  • Milestone changed from sage-combinat to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from assigned to closed

Closing this ticket as a duplicate of #5794.

Note: See TracTickets for help on using tickets.