Opened 12 years ago

Closed 12 years ago

#5830 closed defect (duplicate)

[with patch, not ready for review] reducible root system fixes

Reported by: bump Owned by: bump
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: combinatorics Keywords:
Cc: sage-combinat Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

The methods simple_roots(), fundamental_weights() and simple_coroots() for the ambient space of a root system are supposed to return a family. This was never correctly implemented for the reducible types, and the patch corrects this.

There are also some changes in weyl_characters.py, where it was assumed that the root system was irreducible in a few places. The patch corrects this.

The patch is probably correct but I haven't confirmed that it applies cleanly to sage-3.4.1.rc3 or that it passes sage --testall so wait to review.

Change History (1)

comment:1 Changed 12 years ago by mabshoff

  • Milestone changed from sage-combinat to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from new to closed

For the record: This is a dupe of #5832.

Cheers,

Michael

Note: See TracTickets for help on using tickets.