Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#5686 closed enhancement (fixed)

mpi4py is very outdated

Reported by: syazdani Owned by: mabshoff
Priority: minor Milestone: sage-4.3
Component: packages: experimental Keywords:
Cc: Merged in:
Authors: William Stein Reviewers: Soroosh Yazdani
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by mabshoff)

mpi4py in the experimental package is version 0.3.1, while the newest version is 1.0.0.

Change History (8)

comment:1 Changed 13 years ago by mabshoff

  • Component changed from optional packages to experimental package
  • Description modified (diff)
  • Milestone set to sage-3.4.2

mpi4py is experimental, not optional.

Cheers,

Michael

comment:2 Changed 13 years ago by syazdani

I have an .spkg for this package now. Here is the link: http://sage.math.washington.edu/home/syazdani/mpi4py-1.0.0.spkg

Soroosh

comment:3 Changed 13 years ago by was

  • Report Upstream set to N/A

I've created a new version here:

http://sage.math.washington.edu/home/wstein/patches/mpi4py-1.1.0.spkg

To build it and test do:

sage -i openmpi-1.1.4 mpi4py-1.1.0.spkg

Then

sage: import mpi4py
sage: help(mpi4py)

Note: I will also update openmpi spkg at #7701

comment:4 Changed 13 years ago by was

  • Status changed from new to needs_review

comment:5 Changed 13 years ago by syazdani

  • Status changed from needs_review to positive_review

comment:6 Changed 13 years ago by was

  • Resolution set to fixed
  • Status changed from positive_review to closed

I posted the spkg.

comment:7 Changed 13 years ago by mhansen

  • Milestone changed from sage-4.3.1 to sage-4.3

comment:8 Changed 13 years ago by mvngu

  • Authors set to William Stein
  • Reviewers set to Soroosh Yazdani
Note: See TracTickets for help on using tickets.