Opened 12 years ago

Closed 12 years ago

#5674 closed enhancement (duplicate)

duplicate of #5673

Reported by: cremona Owned by: was
Priority: minor Milestone: sage-3.4.1
Component: number theory Keywords: elliptic curve twist
Cc: wuthrich Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

The patch does the following related things:

  1. Implements in ell_generic functions is_quadratic_twist(), is_quartic_twist(), is_sextic_twist(), which detect twists between curves (returning the appropriate twisting paramenter)
  2. Deprecates the EllipticCurve?(j) constructor, replacing it with EllipticCurve_from_j(j). Over Q this gives the minimal twist, i.e. a curve with the correct j and minimal conductor.
  3. Rewrites the function minimal_quadratic_twist() introduced in #4667 to use the previous function, with extra work in case j=0, 1728 since we need the minimal quadratic twist, not the minimal twist.

There is likely to be a necessary change to documentation (pages 38 and 39 of the tutorial) which have not yet been made.

The patch is based on 3.4.1.alpha0 + patches at #4667. I have tested all files in sage/schemes/elliptic_curves. There are two failures in sha_tate which I do not understand, so I am posting the patch anyway.

Attachments (1)

twist.patch (25.2 KB) - added by cremona 12 years ago.
apply to 3.4.1.apha0 + #4667 patches

Download all attachments as: .zip

Change History (2)

Changed 12 years ago by cremona

apply to 3.4.1.apha0 + #4667 patches

comment:1 Changed 12 years ago by cremona

  • Resolution set to duplicate
  • Status changed from new to closed
  • Summary changed from [with patch, needs review] Enhanced handling of elliptic curve twists to duplicate of #5673

Sorry I must have pressed too many buttons...

Note: See TracTickets for help on using tickets.