Opened 12 years ago

Closed 12 years ago

#5559 closed defect (duplicate)

roots issue on fedora core 32-bit and gcc 4.3.3

Reported by: was Owned by: mabshoff
Priority: blocker Milestone: sage-duplicate/invalid/wontfix
Component: doctest coverage Keywords:
Cc: cwitty Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

>> x86-Linux-fc (cicero)
>>
>> The following tests failed:
>>
>>        sage -t  "devel/sage/sage/rings/polynomial/complex_roots.py"
>
> Could you send the output of this test failing?

sage -t  "devel/sage/sage/rings/polynomial/complex_roots.py"
**********************************************************************
File "/home/mariah/sage/sage-3.4-x86-Linux-fc/devel/sage/sage/rings/polynomial/c
omplex_roots.py", line 271:
   sage: complex_roots(x^2 + 27*x + 181)
Expected:
   [(-14.61803398874990?..., 1), (-12.3819660112501...? + 0.?e-27*I, 1)]
Got:
   [(-12.3819660112501?, 1), (-14.61803398874990? + 0.?e-27*I, 1)]
**********************************************************************
1 items had failures:

Change History (4)

comment:1 Changed 12 years ago by mabshoff

  • Summary changed from roots issue on fedora core 32-bit to roots issue on fedora core 32-bit and gcc 4.3.3

This is "only" a problem with gcc 4.3.3.

Cheers,

Michael

comment:2 Changed 12 years ago by mabshoff

  • Milestone changed from sage-3.4.2 to sage-3.4.1

This is a 3.4.1 blocker if there ever was one :)

Cheers,

Michael

comment:3 Changed 12 years ago by mabshoff

  • Cc cwitty added

After chatting to cwitty about this problem a couple weeks ago: we can just use another polynomial since the specific choice is irrelevant.

Cheers,

Michael

comment:4 Changed 12 years ago by mabshoff

  • Milestone changed from sage-3.4.1 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from new to closed

This is a dupe of #5378.

Cheers,

Michael

Note: See TracTickets for help on using tickets.