Opened 12 years ago

Closed 12 years ago

#5515 closed defect (duplicate)

"make" attempts to build documentation even if the build fails

Reported by: cwitty Owned by: mabshoff
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: build Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

In $SAGE_ROOT/spkg/install:

time make -f standard/deps $1
"$SAGE_ROOT"/sage -docbuild --jsmath all html

This hides the true cause of a build error if something goes wrong -- you see a totally irrelevant error about failing to build the documentation, instead of a useful error about whatever went wrong with the build.

Change History (3)

comment:1 Changed 12 years ago by tornaria

I was hit by this issue in three different ways, with different errors reported:

  1. error building gmp-mpir-0.9 (#5516), when I didn't have system wide python installed, the error reported in the last line in the compilation was:
    /opt/sage/sage-3.4/local/bin/sage-sage: line 852: python: command not found
    
  2. same error in gmp-mpir-0.9 (#5516), after installing system wide python, the error reported was:
    python: can't open file '/opt/sage/sage-3.4/devel/sage/doc/common/builder.py': [Errno 2] No such file or directory
    
  3. error building cvxopt-0.9.p7 (#5517), the error reported was:
    ImportError: No module named jinja
    

I think all of these misreporting are due to the issue reported in this ticket. The actual issues in gmp-mpir-0.9 and cvxopt-0.9.p7 are reported in #5516 and #5517 resp.

comment:2 Changed 12 years ago by timdumol

  • Summary changed from "make" attempts to build documentation even if the build fails to [Duplicate, please close] "make" attempts to build documentation even if the build fails

Duplicate of #6295.

comment:3 Changed 12 years ago by mvngu

  • Milestone changed from sage-4.1.2 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from new to closed
  • Summary changed from [Duplicate, please close] "make" attempts to build documentation even if the build fails to "make" attempts to build documentation even if the build fails

Close this ticket as a duplicate of #6295.

Note: See TracTickets for help on using tickets.