Opened 12 years ago

Closed 12 years ago

#5504 closed enhancement (duplicate)

[duplicate] fix shell script "sage"

Reported by: dangrayson Owned by: was
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: user interface Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

It would be great if the line

"$SAGE_ROOT/local/bin/sage-sage" $*

in the top level script 'sage' would be changed to

"$SAGE_ROOT/local/bin/sage-sage" "$@"

so it doesn't split up command line arguments that happen to have spaces in them.

Change History (4)

comment:1 Changed 12 years ago by mabshoff

  • Milestone set to sage-3.4.1

comment:2 Changed 12 years ago by GeorgSWeber

The intended change already has happened and was part of trac #4354 : "loading a file with spaces in the filename doesn't work"

comment:3 follow-up: Changed 12 years ago by GeorgSWeber

  • Summary changed from fix shell script "sage" to [duplicate] fix shell script "sage"

Am I allowed to close this?

comment:4 in reply to: ↑ 3 Changed 12 years ago by mabshoff

  • Milestone changed from sage-3.4.1 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from new to closed

Replying to GeorgSWeber:

This is indeed a dupe of #4354.

Am I allowed to close this?

Nope, the release manager does that after verifying that it is a dupe. And I have to state that you are right, so closed as a dupe :)

Cheers,

Michael

Note: See TracTickets for help on using tickets.