Opened 12 years ago

Closed 4 years ago

#5503 closed defect (duplicate)

"cmp" method failing on objects in the pickle jar

Reported by: nbruin Owned by: cwitty
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: misc Keywords: universal comparison, transitivity, coercion
Cc: jakobkroeker Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

The following piece of code loads the pickle jar and tries to compare each pair of members. In my 3.4, it currently segfaults.

If sage is to have universal comparison, these comparisons should all occur without error. The next step would be to ensure that results are consistent with transitivity.

L=[]
M=[]
#change this location to point to your own pickle jar
path="/usr/local/sage/default/tmp/pickle_jar-3.4"

for n in sorted(os.listdir(path)):
  if n.endswith(".sobj") and not(n in M):
    print n
    L.append(load(path+"/"+n))

for i in [1..len(L)-1]:
    for j in range(i):
        try:
            _=cmp(L[i],L[j])
        except:
            print [i,j]

Change History (6)

comment:1 Changed 8 years ago by jdemeyer

  • Milestone changed from sage-5.11 to sage-5.12

comment:2 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.1 to sage-6.2

comment:3 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.2 to sage-6.3

comment:4 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.3 to sage-6.4

comment:5 Changed 4 years ago by jakobkroeker

  • Cc jakobkroeker added
  • Report Upstream set to N/A

comment:6 Changed 4 years ago by jdemeyer

  • Milestone changed from sage-6.4 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #16311.

Note: See TracTickets for help on using tickets.