Opened 14 years ago

Closed 13 years ago

Last modified 13 years ago

#5481 closed defect (fixed)

[with patch, positive review] devel/doc/output/* should be filtered from the list of files to doctest

Reported by: Michael Abshoff Owned by: Mike Hansen
Priority: critical Milestone: sage-4.1
Component: doctest coverage Keywords:
Cc: Mike Hansen Merged in: sage-4.1.alpha3
Authors: John Palmieri Reviewers: Mike Hansen
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

There can be many rst files under devel/doc/output - those should be filtered from the list of files to doctest since they are duplicate doctests from the main Sage library in many cases.

Cheers,

Michael

Attachments (1)

trac_5481_scripts.patch (1.2 KB) - added by John Palmieri 13 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 13 years ago by John Palmieri

Has this been fixed? The file sage-maketest looks good to me already.

comment:2 Changed 13 years ago by William Stein

Priority: blockercritical

comment:3 Changed 13 years ago by John Palmieri

Maybe sage-ptest needs changing. I'm still trying to figure out what the issue is here.

Changed 13 years ago by John Palmieri

Attachment: trac_5481_scripts.patch added

comment:4 Changed 13 years ago by John Palmieri

Summary: devel/doc/output/* should be filtered from the list of files to doctest[with patch, needs review] devel/doc/output/* should be filtered from the list of files to doctest

Here's a patch. (The first change -- deleting all.py and init.py -- comes from #6108.)

comment:5 Changed 13 years ago by Mike Hansen

Authors: John Palmieri
Owner: changed from Michael Abshoff to Mike Hansen
Reviewers: Mike Hansen
Status: newassigned
Summary: [with patch, needs review] devel/doc/output/* should be filtered from the list of files to doctest[with patch, positive review] devel/doc/output/* should be filtered from the list of files to doctest

Looks good to me.

comment:6 Changed 13 years ago by Kelly Boothby

Merged in: sage-4.1.alpha2
Resolution: fixed
Status: assignedclosed

comment:7 Changed 13 years ago by Robert Miller

Merged in: sage-4.1.alpha2sage-4.1.alpha3
Note: See TracTickets for help on using tickets.