Opened 11 years ago

Closed 7 years ago

Last modified 7 years ago

#5458 closed enhancement (duplicate)

Refactor set partitions with a single entry points in global name space for the various cartan types

Reported by: nthiery Owned by: mhansen
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: combinatorics Keywords:
Cc: sage-combinat Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description (last modified by nthiery)

Refactor the set partitions code to have a single entry point in the global name space for the various types. I.e. from the user point of view, replace the following names in the global name space:

By something like:

SetPartitions?(..., type=["A",3])

See also: http://groups.google.com/group/sage-devel/msg/a49f3288fca1b75c

Change History (4)

comment:1 Changed 11 years ago by nthiery

  • Description modified (diff)

comment:2 Changed 11 years ago by nthiery

  • Cc sage-combinat added

comment:3 Changed 7 years ago by mhansen

  • Milestone changed from sage-5.11 to sage-duplicate/invalid/wontfix
  • Report Upstream set to N/A
  • Resolution set to duplicate
  • Status changed from new to closed

I think we can close this as a duplicate of #14234 which actually has some work being done on it.

comment:4 Changed 7 years ago by tscrim

This is not a duplicate of #14234 since that does not remove these from the global namespace, deprecate them, nor correctly pass along the correct object. There is still work to be done here, so please reopen this ticket.

Note: See TracTickets for help on using tickets.