Opened 14 years ago

Closed 14 years ago

#5455 closed defect (fixed)

[with patch; positive review] gap-4.4.12 -- workspaces broken on iras (itanium Linux)

Reported by: William Stein Owned by: Michael Abshoff
Priority: blocker Milestone: sage-3.4
Component: packages: standard Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by William Stein)

Saving workspaces is broken in GAP SUSE Itanium.

sage: !gap
    
            #########           ######         ###########           ###  
         #############          ######         ############         ####  
        ##############         ########        #############       #####  
       ###############         ########        #####   ######      #####  
      ######         #         #########       #####    #####     ######  
     ######                   ##########       #####    #####    #######  
     #####                    ##### ####       #####   ######   ########  
     ####                    #####  #####      #############   ###  ####  
     #####     #######       ####    ####      ###########    ####  ####  
     #####     #######      #####    #####     ######        ####   ####  
     #####     #######      #####    #####     #####         #############
      #####      #####     ################    #####         #############
      ######     #####     ################    #####         #############
      ################    ##################   #####                ####  
       ###############    #####        #####   #####                ####  
         #############    #####        #####   #####                ####  
          #########      #####          #####  #####                ####  
                                                                          
     Information at:  http://www.gap-system.org
     Try '?help' for help. See also  '?copyright' and  '?authors'
    
   Loading the library. Please be patient, this may take a while.
GAP4, Version: 4.4.12 of 17-Dec-2008, ia64-unknown-linux-gnu-gcc
gap> SaveWorkspace("a");
true
gap>
wstein@iras:/tmp/wstein/sage-3.4.alpha0-ia64-Linux/x> ls
?ǎ?

Attachments (1)

trac_5455.patch (848 bytes) - added by William Stein 14 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 14 years ago by William Stein

Description: modified (diff)

comment:2 Changed 14 years ago by William Stein

Summary: gap-4.4.12 -- broken on iras (itanium Linux)gap-4.4.12 -- workspaces broken on iras (itanium Linux)

Basically the filename option to SaveWorkspace? seems to be randomly corrupted.

Changed 14 years ago by William Stein

Attachment: trac_5455.patch added

comment:3 Changed 14 years ago by William Stein

Priority: majorblocker
Summary: gap-4.4.12 -- workspaces broken on iras (itanium Linux)[with patch; needs review] gap-4.4.12 -- workspaces broken on iras (itanium Linux)

I've posted a patch that just disables the workspace caching optimization completely for Itanium. I wrote workspace caching for gap (long ago) and it is 100% just an optimization -- things should be functionally equivalent but just the first time one does "gap(...)" it is slower.

NOTE: I also tried compiling gap with -O0 and that didn't fix this problem.

comment:4 Changed 14 years ago by William Stein

I'm testing my patch. I noticed that this fails:

File "/home/wstein/iras/build/sage-3.4.alpha0/devel/sage/doc/en/constructions/linear_codes.rst", line 29:
    sage: C.minimum_distance()
Exception raised:
    RuntimeError: Gap produced error output
    Variable: 'GeneratorMatCode' must have a value

I'm guessing the problem is that when use_workspace_cache is False, then certain packages don't get loaded, maybe. This would be another separate bug in the gap interface.

comment:5 Changed 14 years ago by Michael Abshoff

Milestone: sage-3.4.1sage-3.4
Summary: [with patch; needs review] gap-4.4.12 -- workspaces broken on iras (itanium Linux)[with patch; positive review] gap-4.4.12 -- workspaces broken on iras (itanium Linux)

Positive review.

Cheers,

Michael

comment:6 Changed 14 years ago by Michael Abshoff

Resolution: fixed
Status: newclosed

Merged in Sage 3.4.final.

Cheers,

Michael

Note: See TracTickets for help on using tickets.