Opened 12 years ago

Closed 10 years ago

#5367 closed defect (duplicate)

bug in composition of power series

Reported by: AlexGhitza Owned by: tbd
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: algebra Keywords: power series composition
Cc: Merged in:
Authors: Reviewers: David Loeffler
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

The following returns an incorrect answer:

sage: S.<z> = QQ[[]]
sage: p = 1 + O(z)
sage: q = 1 + z
sage: p(q)          # should return O(z^0)
1

This was reported via "report a problem" from the notebook.

Change History (9)

comment:1 Changed 12 years ago by AlexGhitza

As pointed out by Ralf Hemmecke on sage-devel, the correct behaviour is not to return 1, but rather to raise an error if q has a constant term.

comment:2 Changed 12 years ago by davidloeffler

I just came across this, which is presumably related:

sage: R.<x> = QQ[[]]
sage: f = 1 + 24*x^11 + 24*x^22 + O(x^33)
sage: f(x^2)
1 + 24*x^22 + 24*x^44 + O(x^86)

The answer should clearly be 1 + 24*x22 + 24*x44 + O(x66). (This is causing some headaches in trying to sort out degeneracy maps for modular forms.)

comment:3 follow-up: Changed 11 years ago by robertwb

  • Report Upstream set to N/A

See also #3979.

comment:4 Changed 11 years ago by cremona

Since this is a duplicate of #3979, I think this ticket should be closed.

comment:5 in reply to: ↑ 3 Changed 10 years ago by fwclarke

Replying to robertwb:

See also #3979.

Which now has a patch.

comment:6 Changed 10 years ago by davidloeffler

  • Status changed from new to needs_review

I concur that this should be closed as duplicate. I'll set it to "positive review" to bring this to the attention of the release manager.

comment:7 Changed 10 years ago by davidloeffler

  • Status changed from needs_review to positive_review

comment:8 Changed 10 years ago by jdemeyer

  • Milestone changed from sage-4.7.1 to sage-duplicate/invalid/wontfix

comment:9 Changed 10 years ago by jdemeyer

  • Resolution set to duplicate
  • Reviewers set to David Loeffler
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.