Opened 12 years ago

Closed 12 years ago

#5247 closed defect (duplicate)

cuspform_lseries() computing sign of functional equation incorrectly

Reported by: mabshoff Owned by: craigcitro
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: modular forms Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

Sal reports: The following computation should produce identical values in the last line:

E=EllipticCurve('37b2')
h=E.modular_form()
Lh = h.cuspform_lseries()
LE=E.lseries()
h.elliptic_curve()==E, Lh(1), LE(1)

The output is:

(True, 0, 0.725681061936153)

I'm running Sage 3.3.alpha3 of sage.math.

The problem seems to be the sign of the functional equation -- it looks like the cuspform_lseries() incorrectly computes it to be -1, forcing the value at s=1 to be 0. In sage/modular/modform/element.py the sign of the functional equation fed into the Dokchister is computed by

e = (-1)**(l/2)*n.atkin_lehner_operator().matrix()[0,0]

which Gonzalo and Mark tell me is not correct.

Change History (1)

comment:1 Changed 12 years ago by mabshoff

  • Milestone changed from sage-3.4.1 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from new to closed

This is a dupe of #5262. William did open the other ticket later, but since #5262 has the better description I am closing this ticket.

Cheers,

Michael

Note: See TracTickets for help on using tickets.