Opened 12 years ago

Closed 11 years ago

#5246 closed defect (duplicate)

installing R package in r.console() doesn't work

Reported by: schilly Owned by: mabshoff
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: packages: standard Keywords:
Cc: mhansen Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

from public "report a problem" bugtracker in the notebook

Installing CRAN packages with r.console() and then install.packages() fails with the error:

"Can't open /home/was/build/sage-3.1.4/local/lib/R/share/sh/dcf.sh". Strange enough, as the Sage version is 3.2.3, not 3.1.4. This can be "fixed" by creating a symlink from /home/was/build/sage-3.1.4 to the real Sage installation, but it would be better if it worked out of the box. R without CRAN is not very useful.

---

Note by me: seems like there is something linked absolutely!

Change History (4)

comment:1 Changed 12 years ago by mabshoff

  • Priority changed from critical to major

This is from a binary not build by that person that seems to have been upgraded in place. I am not sure this is reproducible, so unless someone can either reproduce this or get the original reporter to give additional info this is "invalid" for me.

R in general does stupid things like ignore RHOME and R_HOME when using cran, so this might very well be an upstream bug.

In general bugs reported via "report a problem" should go to the groups first before anyone opens a ticket.

And this certainly isn't critical.

Cheers,

Michael

comment:2 Changed 11 years ago by kcrisman

  • Cc mhansen added
  • Report Upstream set to N/A

To release manager: I recommend this be closed, as it seems to be a duplicate of #4959.

comment:3 Changed 11 years ago by kcrisman

This is apparently fixed by #6532.

comment:4 Changed 11 years ago by mvngu

  • Milestone changed from sage-4.3.2 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from new to closed

Close as duplicate of #4959.

Note: See TracTickets for help on using tickets.