Opened 14 years ago

Closed 14 years ago

#5104 closed defect (fixed)

[with patch, positive review] setup.py dependency checking issues

Reported by: Craig Citro Owned by: Michael Abshoff
Priority: minor Milestone: sage-3.3
Component: build Keywords:
Cc: Sébastien Barthélemy, Robert Bradshaw Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

In addition to the problems fixed on trac #5060, we also have the following, reported by sbarthelemy:

Hello,

reading the code, I see another problem if ones has the following line in its .pyx:

cimport mod#mycomment

In such a case, we'll look for a dependency mod#mycomment.pxd instead of mod.pxd.

Attachments (1)

5104-cimport-dep.patch (822 bytes) - added by Robert Bradshaw 14 years ago.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 14 years ago by Craig Citro

Cc: Sébastien Barthélemy Robert Bradshaw added

comment:2 Changed 14 years ago by Mike Hansen

Cc: Sébastien Barthélemy Robert Bradshaw removed
Milestone: sage-duplicate/invalid/wontfix
Resolution: duplicate
Status: newclosed

I beat you to it Craig :-)

This is a duplicate of #5103.

comment:3 Changed 14 years ago by Craig Citro

Resolution: duplicate
Status: closedreopened

comment:4 Changed 14 years ago by Craig Citro

Cc: Sébastien Barthélemy Robert Bradshaw added

Oops -- Mike and I made tickets at the same time; apparently we closed each other's tickets at the same time, too.

We'll keep this one open.

comment:5 Changed 14 years ago by Robert Bradshaw

Summary: setup.py dependency checking issues[with patch, needs review] setup.py dependency checking issues

comment:6 Changed 14 years ago by Michael Abshoff

Milestone: sage-duplicate/invalid/wontfixsage-3.3

comment:7 Changed 14 years ago by Michael Abshoff

Milestone: sage-3.4.1sage-3.3

This also seems like a worthwhile fix to be in 3.3

Cheers,

Michael

comment:8 Changed 14 years ago by Michael Abshoff

Summary: [with patch, needs review] setup.py dependency checking issues[with patch, positive review] setup.py dependency checking issues

Positive review & good catch.

Cheers,

Michael

comment:9 Changed 14 years ago by Michael Abshoff

Summary: [with patch, positive review] setup.py dependency checking issues[with patch, needs work] setup.py dependency checking issues

Arrg, this code actually does introduce a problem since \w does not include the directory separator /. Hence:

Installing c_lib
scons: `install' is up to date.
Updating Cython code....
Traceback (most recent call last):
  File "setup.py", line 510, in <module>
    queue = compile_command_list(ext_modules, deps)
  File "setup.py", line 470, in compile_command_list
    dep_file, dep_time = deps.newest_dep(f)
  File "setup.py", line 385, in newest_dep
    for f in self.all_deps(filename):
  File "setup.py", line 366, in all_deps
    for f in self.immediate_deps(filename):
  File "setup.py", line 348, in immediate_deps
    self._deps[filename] = self.parse_deps(filename)
  File "setup.py", line 338, in parse_deps
    raise IOError, "could not find dependency %s included in %s."%(path, filename)
IOError: could not find dependency sage/finance/sage.pxd included in sage/finance/time_series.pyx.
sage: There was an error installing modified sage library code.

Sorry for the hasty review :(

Cheers,

Michael

comment:10 Changed 14 years ago by Michael Abshoff

Milestone: sage-3.3sage-3.4.1

I am cleaning up the 3.3 milestone. If a patch with positive review is put up to this ticket on time it might make it into 3.3.

Cheers,

Michael

Changed 14 years ago by Robert Bradshaw

Attachment: 5104-cimport-dep.patch added

comment:11 Changed 14 years ago by Robert Bradshaw

Summary: [with patch, needs work] setup.py dependency checking issues[with patch, needs review] setup.py dependency checking issues

Updated the patch.

comment:12 Changed 14 years ago by Michael Abshoff

Milestone: sage-3.4.1sage-3.3
Summary: [with patch, needs review] setup.py dependency checking issues[with patch, positive review] setup.py dependency checking issues

Looks good to me. The complete Sage library dependency tree is parse successfully and also builds from scratch.

Cheers,

Michael

comment:13 Changed 14 years ago by Michael Abshoff

Resolution: fixed
Status: reopenedclosed

Merged in Sage 3.3.rc3.

Cheers,

Michael

Note: See TracTickets for help on using tickets.