Opened 12 years ago

Closed 12 years ago

#5103 closed defect (duplicate)

setup.py: dependency checking does not ignore comments

Reported by: mhansen Owned by: mabshoff
Priority: major Milestone: sage-3.3
Component: build Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

*

Hello,

reading the code, I see another problem if ones has the following line in its .pyx:

cimport mod#mycomment

I such a case, we'll look for a dependency mod#mycomment.pxd instead of mod.pxd.

Otherwise, the patch solves the aforementioned problems.

Cheers

Change History (1)

comment:1 Changed 12 years ago by craigcitro

  • Resolution set to duplicate
  • Status changed from new to closed

This is a dupe of #5104.

Note: See TracTickets for help on using tickets.