Opened 12 years ago

Closed 12 years ago

#5054 closed enhancement (duplicate)

add support for doctesting worksheets

Reported by: mhansen Owned by: mabshoff
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: doctest coverage Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

If we want to ship a collection of worksheets in the future, we need some way to doctest them.

One solution would be to go through a worksheet text file, run through the cells, and make sure newly computed output matches up with the output stored in the file.

Change History (3)

comment:1 Changed 12 years ago by mabshoff

  • Milestone changed from sage-3.4 to sage-3.4.1

3.4 is for ReST tickets only.

Cheers,

Michael

comment:2 Changed 12 years ago by jhpalmieri

  • Summary changed from add support for doctesting worksheets to [duplicate] add support for doctesting worksheets

This is a duplicate of #116. Please close it.

comment:3 Changed 12 years ago by mvngu

  • Milestone changed from sage-4.1.1 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from new to closed
  • Summary changed from [duplicate] add support for doctesting worksheets to add support for doctesting worksheets
Note: See TracTickets for help on using tickets.