Opened 13 years ago

Closed 12 years ago

#4849 closed enhancement (duplicate)

add functionality for computing Heegner points to Sage

Reported by: mabshoff Owned by: was
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: number theory Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

See #4848 for a motivation. Attached is some Magma code, but note that according to William

Then the file heegner.py should be attached to that ticket, since to do that 
ticket, one might want to port some of what's in there to Sage. That said, it's 
not so simple, since better algorithms for computing Heegner points were found 
after that code was written.

Attachments (1)

heegner.py (12.1 KB) - added by mabshoff 13 years ago.
This is mostly Magma code

Download all attachments as: .zip

Change History (5)

Changed 13 years ago by mabshoff

This is mostly Magma code

comment:1 Changed 13 years ago by mabshoff

  • Type changed from defect to enhancement

comment:2 Changed 12 years ago by davidloeffler

  • Milestone changed from sage-wishlist to sage-4.1.1
  • Summary changed from add functionality for computing Heegner points to Sage to [fixed by #6045, positive review] add functionality for computing Heegner points to Sage

This is fixed by #6045. I'm flagging this to "positive review" so it will come to the attention of mvngu, who has the authority to close tickets as 4.1.1 release manager.

comment:3 Changed 12 years ago by mvngu

  • Summary changed from [fixed by #6045, positive review] add functionality for computing Heegner points to Sage to [see #6045, needs work] add functionality for computing Heegner points to Sage

The patches on #6045 result in some numerical noise. Once that is fixed, this ticket can get positive review. At the moment, I don't have the privilege to close tickets. But I've merged some tickets in my tree. If you're interested, refer to the file

http://sage.math.washington.edu/home/mvngu/release/merged-tkt.txt

comment:4 Changed 12 years ago by mvngu

  • Milestone changed from sage-4.1.1 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from new to closed
  • Summary changed from [see #6045, needs work] add functionality for computing Heegner points to Sage to add functionality for computing Heegner points to Sage

I'm closing this as a duplicate of #6045.

Note: See TracTickets for help on using tickets.