Opened 12 years ago

Closed 12 years ago

#4781 closed defect (duplicate)

creation of relative number fields when defining polynomial not integral no longer broken

Reported by: was Owned by: davidloeffler
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: number fields Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

sage: K.<a> = NumberField(x^2 + 1)
sage: L.<b> = NumberField(K['y'].0^2 + 1/2)
---------------------------------------------------------------------------
PariError                                 Traceback (most recent call last)

/Users/wstein/sage/build/sage-3.2.2.alpha0/<ipython console> in <module>()

/Users/wstein/sage/build/sage-3.2.2.alpha0/local/lib/python2.5/site-packages/sage/rings/number_field/number_field.pyc in NumberField(polynomial, name, check, names, cache, embedding)
    374 
    375     if isinstance(R, NumberField_generic):
--> 376         S = R.extension(polynomial, name, check=check)
    377         if cache:
    378             _nf_cache[key] = weakref.ref(S)

/Users/wstein/sage/build/sage-3.2.2.alpha0/local/lib/python2.5/site-packages/sage/rings/number_field/number_field.pyc in extension(self, poly, name, names, check, embedding)
   2570         if name is None:
   2571             raise TypeError, "the variable name must be specified."
-> 2572         return NumberField_relative(self, poly, str(name), check=check, embedding=embedding)
   2573 
   2574     def factor(self, n):

/Users/wstein/sage/build/sage-3.2.2.alpha0/local/lib/python2.5/site-packages/sage/rings/number_field/number_field.pyc in __init__(self, base, polynomial, name, latex_name, names, check, embedding)
   4567 
   4568         self.__pari_relative_polynomial = pari(str(polynomial_y))
-> 4569         self.__rnf = self.__base_nf.rnfinit(self.__pari_relative_polynomial)
   4570         
   4571         self.__base_field = base

/Users/wstein/sage/build/sage-3.2.2.alpha0/local/lib/python2.5/site-packages/sage/libs/pari/gen.so in sage.libs.pari.gen._pari_trap (sage/libs/pari/gen.c:38578)()

PariError: impossible inverse modulo:  (36)
> /Users/wstein/sage/build/sage-3.2.2.alpha0/gen.pyx(8050)sage.libs.pari.gen._pari_trap (sage/libs/pari/gen.c:38578)()

Change History (4)

comment:1 Changed 12 years ago by fwclarke

  • Milestone changed from sage-3.4.2 to sage-3.4.1
  • Priority changed from major to minor
  • Summary changed from creation of relative number fields when defining polynomial not integral is broken to creation of relative number fields when defining polynomial not integral no longer broken

Seems to be fine now (3.4):

----------------------------------------------------------------------
| Sage Version 3.4, Release Date: 2009-03-10                         |
| Type notebook() for the GUI, and license() for information.        |
----------------------------------------------------------------------
sage: K.<a> = NumberField(x^2 + 1)
sage: L.<b> = NumberField(K['y'].0^2 + 1/2)
sage: L
Number Field in b with defining polynomial y^2 + 1/2 over its base field

comment:2 Changed 12 years ago by davidloeffler

  • Component changed from number theory to number fields
  • Owner changed from was to davidloeffler

comment:3 Changed 12 years ago by davidloeffler

  • Summary changed from creation of relative number fields when defining polynomial not integral no longer broken to [duplicate, positive review] creation of relative number fields when defining polynomial not integral no longer broken

In the above example, you can create the field L but you can't do much with it (for instance, L.absolute_discriminant() fails). But I would argue that this is covered by ticket #252. I propose closing this ticket as "duplicate".

comment:4 Changed 12 years ago by mvngu

  • Milestone changed from sage-4.1.1 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from new to closed
  • Summary changed from [duplicate, positive review] creation of relative number fields when defining polynomial not integral no longer broken to creation of relative number fields when defining polynomial not integral no longer broken

Closing this as a duplicate of #252.

Note: See TracTickets for help on using tickets.