Opened 12 years ago

Closed 12 years ago

#4716 closed defect (duplicate)

[with patch, needs review] Small bug in KodairaSymbol

Reported by: cremona Owned by: was
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: number theory Keywords: Elliptic curves
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

#4412 had a buglet: for Kodaira Class Im the _roman field was not being set (it should be 1). This is only currently used in the tamagawa_exponent() function for elliptic curves over number fields.

One-line patch coming up, plus a corresponding doctest.

This was reported by Tobias Nagel:

sage: E=EllipticCurve('117a3');                        
sage: E.tamagawa_exponent(13)
---------------------------------------------------------------------------
AttributeError                            Traceback (most recent call last)

/home/tobi/test_Sint/<ipython console> in <module>()

/home/tobi/sage/local/lib/python2.5/site-packages/sage/schemes/elliptic_curves/ell_rational_field.pyc in tamagawa_exponent(self, p)
 2190             return cp
 2191         ks = self.kodaira_type(p)
-> 2192         if ks._roman==1 and ks._n%2==0 and ks._starred:
 2193             return 2
 2194         return 4

AttributeError: 'KodairaSymbol_class' object has no attribute '_roman'

The patch is based on 3.2.1.

Attachments (1)

sage-trac-4715.patch (1.3 KB) - added by cremona 12 years ago.

Download all attachments as: .zip

Change History (3)

Changed 12 years ago by cremona

comment:1 Changed 12 years ago by mabshoff

This is a dupe of #4715.

Cheers,

Michael

comment:2 Changed 12 years ago by mabshoff

  • Milestone changed from sage-3.2.2 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.