Opened 13 years ago

Closed 13 years ago

#4711 closed defect (fixed)

fix ptest race condition: "file not found"

Reported by: mabshoff Owned by: gfurnish
Priority: blocker Milestone: sage-3.2.2
Component: build Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

[10:16pm] mabshoff: gfurnish: just hit another race condition with ptest:
[10:16pm] mabshoff: sage -t  devel/sage/sage/gsl/gsl_sf_result.pxi
[10:16pm] mabshoff: Error running /scratch/mabshoff/release-cycle/sage-3.2.2.alpha0/local/bin/sage-doctest, since file gsl_sf_result.pxi does not exist.
[10:16pm] mabshoff: It is probably the same as the one where the doctest is only half written
[10:16pm] gfurnish: hm 
[10:17pm] gfurnish: don't touch anything
[10:17pm] gfurnish: let me look in your directory
[10:17pm] mabshoff: mk
[10:17pm] You are now known as mabs|ds0.
[10:17pm] You are now known as mab|ds9.
[10:17pm] mab|ds9:
[10:17pm] gfurnish: nothing in tmp dir?
[10:18pm] gfurnish: oh nm
[10:18pm] mab|ds9: The last line of the output was also "sage -t  devel/sage/sage/gsl/gsl_sf_result.pxi # File not found"
[10:18pm] gfurnish: that sounds like a ptest bug.
[10:19pm] gfurnish: yeah um
[10:19pm] gfurnish: I know whats causing that problem
[10:19pm] gfurnish: make a ticket
[10:20pm] gfurnish: I fixed the bug in pbuild
[10:20pm] mab|ds9: Is it orthogonal to the other race condition then I assume?
[10:21pm] gfurnish: I think so

Change History (3)

comment:1 Changed 13 years ago by mabshoff

  • Priority changed from major to blocker

Gary,

it would be excellent if you could make this a priority since I have been hitting this race condition way more often than I used to.

Cheers,

Michael

comment:2 Changed 13 years ago by gfurnish

  • Status changed from new to assigned

This is fixed by #4699 because previously threads were changing the current directory, and current directory is a per process state and not a per thread state. By switching to pyprocessing, which uses processes instead of threads, the problem is removed.

comment:3 Changed 13 years ago by mabshoff

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed by #4699 merged in Sage 3.2.2.alpha2

Note: See TracTickets for help on using tickets.