Opened 12 years ago

Closed 12 years ago

#4694 closed defect (duplicate)

?? for decorated functions shows the source of the decorator

Reported by: whuss Owned by: was
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: user interface Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

sage: plot??
Type:           function
Base Class:     <type 'function'>
String Form:    <function plot at 0xb6f1f454>
Namespace:      Interactive
File:           /.../site-packages/sage/plot/misc.py
Definition:     plot(*args, **kwds)
Source:
        @wraps(func)
        def wrapper(*args, **kwds):
            for old_name, new_name in self.renames.items():
                if kwds.has_key(old_name) and not kwds.has_key(new_name):
                    kwds[new_name] = kwds[old_name]
                    del kwds[old_name]
            return func(*args, **kwds)

Change History (1)

comment:1 Changed 12 years ago by mabshoff

  • Milestone changed from sage-3.2.2 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from new to closed

Hi,

this is a dupe of #4672. There is a patch over there that needs one doctest fixed to be merged, so feel free to look into it.

Cheers,

Michael

Note: See TracTickets for help on using tickets.