Opened 12 years ago

Closed 12 years ago

#4607 closed defect (duplicate)

double backslash not properly handled in latex mode

Reported by: schilly Owned by: boothby
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: notebook Keywords:
Cc: p.a.rombouts@… Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

from public bug collection:

Normally a double backslash '
' forces a new line in LaTeX. However, when I type the following in a notebook input cell:

%latex
First line.\\
Second line.

the output looks like this:

      First line.line.

After a little fiddling, I discovered this effect can be achieved using three backslashes instead of two, but this is not correct behavior. I first discovered this problem when I tried to render something like this in a sage notebook:

%latex
\[\theta(x)=\begin{cases}
0 & (x<0) \\
1 & (x\ge 0)
\end{cases}\]

The '1' is missing in the rendered output. The desired output can be obtained by using triple backslashes, but as I noted before, the is not correct behavior.


probably just needs proper escaping.

Change History (1)

comment:1 Changed 12 years ago by mhansen

  • Milestone changed from sage-3.4.1 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #3201. I'll try to have the fix here in the next few days.

Note: See TracTickets for help on using tickets.