Opened 12 years ago

Closed 12 years ago

#4382 closed defect (fixed)

[with patch; positive review] notebook -- use sage-native-execute for ssh'ing for remote pexpect

Reported by: was Owned by: boothby
Priority: critical Milestone: sage-3.2
Component: notebook Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

This patch fixes a major bug that would make it nearly impossible to setup a secure sage server. All it does is make sure ssh runs without the Sage environment setup, which is good because of version mismatches.

Attachments (1)

sage-4382.patch (1.4 KB) - added by was 12 years ago.

Download all attachments as: .zip

Change History (3)

Changed 12 years ago by was

comment:1 Changed 12 years ago by mabshoff

  • Summary changed from [with patch; needs review] notebook -- use sage-native-execute for ssh'ing for remote pexpect to [with patch; positive review] notebook -- use sage-native-execute for ssh'ing for remote pexpect

Patch is good, positive review.

Cheers,

Michael

comment:2 Changed 12 years ago by mabshoff

  • Resolution set to fixed
  • Status changed from new to closed

Merged in Sage 3.2.alpha2

Note: See TracTickets for help on using tickets.