Opened 14 years ago

Closed 14 years ago

#4377 closed defect (fixed)

[with patch; positive review] Building the Sage library with parallel make is broken on OSX 10.4

Reported by: mabshoff Owned by: mabshoff
Priority: critical Milestone: sage-3.2
Component: build Keywords:
Cc: justin Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

exporting MAKE=make -j2 leads to

Traceback (most recent call last):
  File "setup.py", line 1545, in <module>
    cython(deps, ext_modules)
  File "setup.py", line 1311, in cython
    execute_list_of_commands(command_list)
  File "setup.py", line 1403, in execute_list_of_commands
    n = 2*number_of_cpus()
TypeError: unsupported operand type(s) for *: 'int' and 'NoneType'
sage: There was an error installing modified sage library code.

on OSX 10.4.

This is caused by #3765.

Cheers,

Michael

Attachments (1)

sage-4377.patch (1.2 KB) - added by was 14 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 14 years ago by mabshoff

Cc: justin added

ok, the issue is simple enough and an extra "\n" in the output:

>>> import os
>>> os.popen2("sysctl -n hw.ncpu")[1].read()
'2\n'

Cheers,

Michael

comment:2 Changed 14 years ago by mabshoff

Ok, the above wasn't the issue. Strange that number_of_cpus() returns None.

Cheers,

Michael

Changed 14 years ago by was

Attachment: sage-4377.patch added

comment:3 Changed 14 years ago by was

Summary: Building the Sage library with parallel make is broken on OSX 10.4[with patch; needs review] Building the Sage library with parallel make is broken on OSX 10.4

comment:4 Changed 14 years ago by mabshoff

Summary: [with patch; needs review] Building the Sage library with parallel make is broken on OSX 10.4[with patch; positive review] Building the Sage library with parallel make is broken on OSX 10.4

The patch fixes the issue.

Cheers,

Michael

comment:5 Changed 14 years ago by mabshoff

Resolution: fixed
Status: newclosed

Merged in Sage 3.2.alpha2

Note: See TracTickets for help on using tickets.