Opened 10 years ago

Closed 10 years ago

#4328 closed defect (worksforme)

bug in roots

Reported by: zimmerma Owned by: somebody
Priority: major Milestone: sage-3.2
Component: basic arithmetic Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

----------------------------------------------------------------------
| SAGE Version 3.1.4, Release Date: 2008-10-16                       |
| Type notebook() for the GUI, and license() for information.        |
----------------------------------------------------------------------

sage: R=PolynomialRing(ZZ, x)
sage: f=R(x^4+1)
sage: f.roots(GF(2))
---------------------------------------------------------------------------
ValueError                                Traceback (most recent call last)
...
ValueError: factorization of 0 not defined

Change History (3)

comment:1 Changed 10 years ago by zimmerma

I should have said it works with vanilla 3.1.4, thus it is most likely related to the recent patches for GF(2)[x] I have applied to my 3.1.4 version.

comment:2 Changed 10 years ago by mabshoff

It works with my current 3.2.alpha0 merge tree:

mabshoff@sage:/scratch/mabshoff/release-cycle/sage-3.2.alpha0$ ./sage
----------------------------------------------------------------------
| SAGE Version 3.1.4, Release Date: 2008-10-16                       |
| Type notebook() for the GUI, and license() for information.        |
----------------------------------------------------------------------

sage: R=PolynomialRing(ZZ, x)
sage: sage: f=R(x^4+1)
sage: sage: f.roots(GF(2))
[(1, 4)]

I suspect the root cause could be #4302.

Cheers,

Michael

comment:3 Changed 10 years ago by malb

  • Resolution set to worksforme
  • Status changed from new to closed

worksforme:

----------------------------------------------------------------------
| SAGE Version 3.1.3, Release Date: 2008-10-14                       |
| Type notebook() for the GUI, and license() for information.        |
----------------------------------------------------------------------
Loading SAGE library. Current Mercurial branch is: test
sage: R=PolynomialRing(ZZ, x)
sage: f=R(x^4+1)
sage: f.roots(GF(2))
[(1, 4)]

sage: P.<x> = PolynomialRing(GF(2))
sage: type(x) # check whether the patch is applied
<type 'sage.rings.polynomial.polynomial_gf2x.Polynomial_GF2X'>

Note that I updates #4302 recently.

Note: See TracTickets for help on using tickets.