Opened 11 years ago

Closed 11 years ago

#4323 closed defect (duplicate)

sage-coverage expects doctests for closures

Reported by: robertwb Owned by: mabshoff
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: doctest coverage Keywords:
Cc: zimmerma Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

Unfortunately, there is often no way to doctest such functions directly, and for some re-writing them as lambda functions is impossible or reduces readability.

Change History (7)

comment:1 Changed 11 years ago by robertwb

  • Component changed from algebra to doctest
  • Owner changed from tbd to mabshoff

comment:2 Changed 11 years ago by zimmerma

  • Cc zimmerma added

comment:3 Changed 11 years ago by mabshoff

  • Milestone set to sage-3.2

comment:4 follow-up: Changed 11 years ago by jhpalmieri

Is this the same as #877?

John (who's not quite sure what "closures" are)

P.S. By the way, I think it takes a certain amount of hubris to write a program like 'sage-coverage' which itself has no doctests or documentation :)

comment:5 in reply to: ↑ 4 Changed 11 years ago by mabshoff

Replying to jhpalmieri:

Is this the same as #877?

John (who's not quite sure what "closures" are)

Not sure.

P.S. By the way, I think it takes a certain amount of hubris to write a program like 'sage-coverage' which itself has no doctests or documentation :)

Yes, this certainly registered rather strongly on my irony meter, but right now there is no coverage for the scripts in local/bin, even though most people agreed that it would be a pretty good idea. This will hopefully happen sooner or later.

Cheers,

Michael

comment:6 Changed 11 years ago by zimmerma

Is this the same as #877?

yes.

comment:7 Changed 11 years ago by mabshoff

  • Milestone changed from sage-3.4.1 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from new to closed

Since this is a dupe of #877 I am closing this ticket as a dupe.

If someone disagrees please reopen.

Cheers,

Michael

Note: See TracTickets for help on using tickets.