Opened 11 years ago

Closed 11 years ago

#4316 closed defect (duplicate)

notebook: '%html $x<y$' doesn't work right

Reported by: jhpalmieri Owned by: boothby
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: notebook Keywords: notebook, %html
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

If I type

%html some math: $x<y$.

in the notebook, then the "<y" gets swallowed. (If I "Edit" the worksheet, I see

<html><font color='black'>some math: <span class="math">x<y</span>.</font></html>

but in the worksheet view I see "some math: x.")

Putting a space between "<" and "y" fixes the problem. Also,

%html some math: $x<6y$.

works just fine, and the same with $x<-y$ and similar things; the problem seems to just be with "<" followed by a letter. The greater than sign seems to present no problems.

Is this related to (or the same problem as) #4245?

Change History (1)

comment:1 Changed 11 years ago by mhansen

  • Milestone changed from sage-3.4.1 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #4245.

Note: See TracTickets for help on using tickets.