Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#4314 closed enhancement (duplicate)

[with patch] Add some functionality to matrices in eclib

Reported by: cremona Owned by: was
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: interfaces Keywords: eclib CremonaModularSymbols
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

The attached patch (based on 3.1.4) makes two changes in libs/cremona/mat*:

  1. Adds getitem methods to the matric class so i,j entries may be extracted;
  2. Changes the conversion to sage of matrices so that matrices over ZZ are constructed instead of ZZ.

These were done as part of a hands-on tutorial William gave to John in Bordeaux.

Change History (2)

comment:1 follow-up: Changed 13 years ago by mhansen

  • Milestone changed from sage-3.2 to sage-duplicate/invalid
  • Resolution set to duplicate
  • Status changed from new to closed

This is a dupe of #4313

comment:2 in reply to: ↑ 1 Changed 13 years ago by cremona

Replying to mhansen:

This is a dupe of #4313

Thanks. One day I'll succeed in creating a new ticket with a pre-existing patch without causing a duplication!

Note: See TracTickets for help on using tickets.