Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#4310 closed defect (fixed)

[with patch, positive review] simplification of the coercion api

Reported by: robertwb Owned by: robertwb
Priority: major Milestone: sage-3.2.1
Component: coercion Keywords:
Cc: mhansen, craigcitro Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

The _has_coerce_map_from_ has been deleted, and the _coerce_map_from_ now can return a boolean or callable as well as a map.

Attachments (2)

4310-coerce-simplification.patch (12.4 KB) - added by robertwb 14 years ago.
trac_4310.patch (13.4 KB) - added by mhansen 14 years ago.

Download all attachments as: .zip

Change History (9)

Changed 14 years ago by robertwb

comment:1 Changed 14 years ago by jason

Grammar comment: "Deprecate" is spelled with an e in the middle, not an i.

Did you know that "deprecate" used to mean "to pray against" (as an evil) and comes from the latin roots de + precari (precari="to pray"). I just learned that when I looked it up. It certainly adds emphasis to deprecation statements if people are praying against the evil of whatever is being deprecated! See http://www.merriam-webster.com/dictionary/deprecate

comment:2 Changed 14 years ago by robertwb

  • Cc craigcitro added

Changed 14 years ago by mhansen

comment:3 Changed 14 years ago by mhansen

  • Summary changed from [with patch, needs review] simplification of the coercion api to [with patch, positive review] simplification of the coercion api

After a rebase and rebuild caused by parent.pxd, I think this is good. It simplifies the coercion interface a fair amount.

Apply only trac_4310.patch

comment:4 Changed 14 years ago by jason

Minor nitpick from before still applies to trac_4310: Deprecate is spelled "Depricate" in the patch. I wouldn't let that hold up the patch going in; just pointing it out.

comment:5 Changed 14 years ago by robertwb

I have *got* to remember how to spell that word...

comment:6 Changed 14 years ago by mabshoff

  • Resolution set to fixed
  • Status changed from new to closed

Merged in Sage 3.2.1.alpha0 - I also fixed the spelling problem pointed out above.

Cheers,

Michael

comment:7 Changed 14 years ago by mabshoff

For the record: I merged trac_4310.patch into Sage 3.2.1.alpha0.

Cheers,

Michael

Note: See TracTickets for help on using tickets.