Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#4299 closed defect (fixed)

[with patch; needs review] sha bound totally busted for rank 0 curves

Reported by: was Owned by: was
Priority: major Milestone: sage-3.1.3
Component: number theory Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

sage: E = EllipticCurve('11a1')
sage: Sha = E.sha()
sage: Sha.bound()
---------------------------------------------------------------------------
AttributeError                            Traceback (most recent call last)

/home/wstein/sage/devel/sage-main/sage/schemes/elliptic_curves/<ipython console> in <module>()

/home/wstein/sage/local/lib/python2.5/site-packages/sage/schemes/elliptic_curves/sha.py in bound(self)
    698         B of primes such that any divisor of Sha is in this list.
    699         """
--> 700         if self.L1_vanishes():
    701             B = self.bound_kolyvagin()
    702         else:

AttributeError: 'Sha' object has no attribute 'L1_vanishes'
sage:
                                        

This is likely easy to fix and was caused by refactoring without enough doctests.

Attachments (1)

sage-4299.patch (1.1 KB) - added by was 14 years ago.
note -- this is against 3.1.2 and sha.py, but sha.py was renamed for 3.1.3, so this patch will need a manual REBASE! but it's better than nothing.

Download all attachments as: .zip

Change History (4)

comment:1 Changed 14 years ago by was

  • Summary changed from sha bound totally busted for rank 0 curves to [with patch; needs review] sha bound totally busted for rank 0 curves

Changed 14 years ago by was

note -- this is against 3.1.2 and sha.py, but sha.py was renamed for 3.1.3, so this patch will need a manual REBASE! but it's better than nothing.

comment:2 Changed 14 years ago by was

  • Resolution set to fixed
  • Status changed from new to closed

this is fixed in 3.1.3 yeah!

comment:3 Changed 14 years ago by mabshoff

  • Milestone changed from sage-3.2 to sage-3.1.3
Note: See TracTickets for help on using tickets.