Opened 13 years ago

Closed 9 years ago

#4258 closed enhancement (duplicate)

switch multiplication of dense matrices over finite prime fields to LinBox

Reported by: malb Owned by: malb
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: linbox Keywords: linbox, linear algebra
Cc: cpernet, burcin, jason, SimonKing Merged in:
Authors: Reviewers: Martin Albrecht
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

sage: A = random_matrix(GF(3),2000,2000)
sage: %time A*A
2000 x 2000 dense matrix over Finite Field of size 3
CPU time: 14.69 s,  Wall time: 15.08 s
sage: %time A._multiply_linbox(A)
2000 x 2000 dense matrix over Finite Field of size 3
CPU time: 2.47 s,  Wall time: 2.55 s

Change History (8)

comment:1 Changed 12 years ago by malb

  • Cc burcin added

Just for the record: Burcin came pretty far during SD16 and IIRC Clément then too over?

comment:2 Changed 11 years ago by jason

  • Cc jason added
  • Report Upstream set to N/A

comment:3 Changed 10 years ago by SimonKing

  • Cc SimonKing added

comment:4 Changed 10 years ago by burcin

  • Component changed from linear algebra to linbox

see #4260 for ongoing work. Shall we close this as a duplicate?

comment:5 Changed 10 years ago by malb

This is a duplicate of #4260 and should be closed.

comment:6 Changed 9 years ago by SimonKing

  • Status changed from new to needs_review

comment:7 Changed 9 years ago by SimonKing

  • Milestone changed from sage-5.0 to sage-duplicate/invalid/wontfix
  • Reviewers set to Martin Albrecht
  • Status changed from needs_review to positive_review

Martin suggested to close this ticket as a duplicate of #4260, and I agree. So, I'm inserting Martin as a reviewer and change it into a positive review (with the suggested resolution "duplicate").

comment:8 Changed 9 years ago by jdemeyer

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.