Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#4252 closed defect (duplicate)

Arrangements / PermutationsNK iterator is broken

Reported by: saliola Owned by: mhansen
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: combinatorics Keywords:
Cc: sage-combinat Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

sage: Arrangements(range(5),4).count()
116
sage: len(list(sage.combinat.permutation.PermutationsNK(5,4).iterator()))
116
sage: factorial(5)/factorial(5-4)
120

They should all be 120. This also doesn't work for the pairs: (4,4), (5, 4), (5, 5), (6, 4), (6, 5), (6, 6), ....

Change History (2)

comment:1 Changed 13 years ago by mhansen

  • Milestone changed from sage-3.2 to sage-duplicate/invalid
  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #4213 which has been fixed in 3.1.3.

comment:2 Changed 12 years ago by nthiery

  • Cc sage-combinat added
Note: See TracTickets for help on using tickets.