Opened 12 years ago

Closed 12 years ago

#4179 closed defect (duplicate)

[with patch, needs review] ell_finite_field.py "long" doctest fails

Reported by: GeorgSWeber Owned by: GeorgSWeber
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: doctest coverage Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

In the file "ell_finite_field.py" change the line 1013 from

sage: for p in prime_range(10000): #long time (~20s)

to

sage: for p in prime_range(32768, 42768): #long time (~20s)

to achieve the same intended amount of testing for the elliptic cirves code as such. (But do not run into an --- as of this writing --- outstanding bug related to 16-Bit signed integers on Mac OS X 10.4.)

Change History (5)

comment:1 Changed 12 years ago by GeorgSWeber

  • Status changed from new to assigned

comment:2 Changed 12 years ago by mabshoff

Georg,

are you planning to post an actual hg patch?

Cheers,

Michael

comment:3 Changed 12 years ago by cremona

I'm not so keen on making this change, since this test was put in originally to show that a previous bug was fixed. It is natural to use a sequence of primes starting at 2, but not so natural to use a sequence like prime_range(32768, 42768).

Given that we are tracking the root problem anyway, can we not live with this one doctest failure which only occurs on one type of machine with the long option anyway?

comment:4 follow-up: Changed 12 years ago by cremona

PS this ticket also duplicates #3760.

comment:5 in reply to: ↑ 4 Changed 12 years ago by mabshoff

  • Milestone changed from sage-3.1.3 to sage-duplicate/invalid
  • Resolution set to duplicate
  • Status changed from assigned to closed

Replying to cremona:

PS this ticket also duplicates #3760.

Ok, I agree with John here and am closing this as a duplicate of #3760. I did comment on that ticket and mentioned this ticket, so the info should not get lost.

Cheers,

Michael

Note: See TracTickets for help on using tickets.