Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#4167 closed defect (duplicate)

wrong colors cornercase in list_plot

Reported by: schilly Owned by: was
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: graphics Keywords:
Cc: wavetable@… Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

published example of this bug

Plotting

x=srange(0, 1.1, 0.5)
w=srange(0, 1.1, 0.5)
xw = zip(x,w)
list_plot(xw, rgbcolor=(0.8, 0.8, 0), pointsize=40)

produces blue and brown dots.

Plotting

x=srange(0, 2.1, 0.5)
w=srange(0, 2.1, 0.5)
xw = zip(x,w)
list_plot(xw, rgbcolor=(0.8, 0.8, 0), pointsize=40)

4 yellow ones.

original report:

list_plot with a list of len == 3 produces 'random' point colors.
it works with len != 3.

i've created a worksheet on the milnix server, that shows the problem.
http://75.75.6.176/home/pub/17

Change History (2)

comment:1 Changed 13 years ago by mabshoff

  • Milestone changed from sage-3.1.3 to sage-duplicate/invalid
  • Resolution set to duplicate
  • Status changed from new to closed

This is a dupe of #2076 which has a patch and will likely be in 3.1.3.

Cheers,

Michael

comment:2 Changed 13 years ago by jason

FYI, with the patch at #2076, both of the above examples correctly produce yellow dots.

Note: See TracTickets for help on using tickets.