Opened 13 years ago

Closed 13 years ago

#4066 closed defect (fixed)

[with patch, positive review] Sage 3.1.2.alpha3: Solaris build fixes for the Sage library

Reported by: mabshoff Owned by: mabshoff
Priority: major Milestone: sage-3.1.2
Component: porting: Solaris Keywords:
Cc: robertwb Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

There are two small fixes needed for the Sage library.

Cheers,

Michael

Attachments (1)

trac_4066_solaris_fixes.patch (3.1 KB) - added by mabshoff 13 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 13 years ago by mabshoff

  • Status changed from new to assigned

comment:2 Changed 13 years ago by mabshoff

  • Milestone changed from sage-combinat to sage-3.1.2

comment:3 Changed 13 years ago by mabshoff

  • Summary changed from [with patch, needs review] Sage 3.1.2.alpha3: Solaris build fixes for the Sage library to [with patch, needs work] Sage 3.1.2.alpha3: Solaris build fixes for the Sage library

Oops, this patch is not ready for review since some doctests fail. I will post an updated patch shortly.

Cheers,

Michael

Changed 13 years ago by mabshoff

comment:4 Changed 13 years ago by mabshoff

  • Cc robertwb added
  • Summary changed from [with patch, needs work] Sage 3.1.2.alpha3: Solaris build fixes for the Sage library to [with patch, needs review] Sage 3.1.2.alpha3: Solaris build fixes for the Sage library

Ok, I have attached an updated patch that

  • passes -ba
  • builds fine on Solaris, OSX and Linux and passes doctests on OSX and Linux

Note that _[A-Z] are numerical constants on BSD and Solaris and should not be used as variable names.

I am CCing Robert since he was involved in writing that code (I think :))

Cheers,

Michael

comment:5 Changed 13 years ago by malb

It applies cleanly against my alpha3, it builds on my 64-bit Linux box, sage -t rings passes which should use this functionality (?)

It SEGFAULTS with sage -tp 2 sage/rings in bernouli_mod_p.pyx though. If that can't be reproduced it might just be a weird combination of patches on my machine.

comment:6 Changed 13 years ago by malb

  • Summary changed from [with patch, needs review] Sage 3.1.2.alpha3: Solaris build fixes for the Sage library to [with patch, positive review] Sage 3.1.2.alpha3: Solaris build fixes for the Sage library

comment:7 Changed 13 years ago by mabshoff

  • Resolution set to fixed
  • Status changed from assigned to closed

Merged in Sage 3.1.2.rc0

Note: See TracTickets for help on using tickets.