Opened 11 years ago

Closed 11 years ago

#3903 closed defect (fixed)

fix mv factorization problem in singular

Reported by: mabshoff Owned by: tbd
Priority: major Milestone: sage-3.1.2
Component: factorization Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

Tom Boothby reported the following problem:

ring r = 0, (y,z), lp;
poly f = 3409/20077273328181816976094527488*y3*z6 + 
51233/40154546656363633952189054976*y3*z5 - 7055/20077273328181816976094527488*y2*z6 + 
42833/13384848885454544650729684992*y3*z4 - 28255/10038636664090908488047263744*y2*z5 
+ 1625/6692424442727272325364842496*y*z6 + 23905/8923232590303029767153123328*y3*z3 - 
637225/80309093312727267904378109952*y2*z4 + 82925/40154546656363633952189054976*y*z5 
- 125/2230808147575757441788280832*z6 - 710155/80309093312727267904378109952*y2*z3 + 
172625/26769697770909089301459369984*y*z4 - 125/247867571952861937976475648*z5 - 
148175/53539395541818178602918739968*y2*z2 + 
1419725/160618186625454535808756219904*y*z3 - 34625/20077273328181816976094527488*z4 + 
265525/53539395541818178602918739968*y*z2 - 111625/40154546656363633952189054976*z3 + 
306625/321236373250909071617512439808*y*z - 77125/35692930361212119068612493312*z2 - 
254125/321236373250909071617512439808*z - 70625/642472746501818143235024879616;
factorize(f,2);

would roughly fail one out of four times.

The singular.spkg at #3194 has a fix for that issue by the Singular team, but we need to add a doctest to verify that the issue is truly fixed.

Cheers,

Michael

Change History (1)

comment:1 Changed 11 years ago by mabshoff

  • Milestone changed from sage-3.2 to sage-3.1.2
  • Resolution set to fixed
  • Status changed from new to closed

This issue has been fixed in Sage 3.1.2 via #3194.

Cheers,

Michael

Note: See TracTickets for help on using tickets.