Opened 13 years ago

Closed 12 years ago

Last modified 12 years ago

#3768 closed task (duplicate)

move jsmath into its own spkg and update to latest upstream (3.6a)

Reported by: tabbott Owned by: mabshoff
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: packages: standard Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

We should move jsmath into its own spkg. Like jquery, there seem to be two copies of it, and it'd be good to get rid of this duplication and track its versioning explicitly.

Change History (11)

comment:1 Changed 13 years ago by jason

I'm working on this.

comment:2 Changed 12 years ago by mabshoff

  • Summary changed from move jsmath into its own spkg to move jsmath into its own spkg and update to latest upstream (3.6a)

Jason,

can you post the spkg here? This should be fairly orthogonal to all the other javascript work you are doing. Since the other patches need to be rebased anyway this would likey make it easier.

comment:4 follow-up: Changed 12 years ago by jason

I think it relies on changes in #4267, though, since it changes the paths that the notebook uses to include jsmath. All of these changes are intertangled at #4267.

comment:5 in reply to: ↑ 4 Changed 12 years ago by mabshoff

Replying to jason:

I think it relies on changes in #4267, though, since it changes the paths that the notebook uses to include jsmath. All of these changes are intertangled at #4267.

Mmh, the jsmath changes should be pretty harmless and as is #4267 is a mess. So taking care of jsmath independently and then redoing #4267 might be an option, but unless somebody else is doing the work I guess it is your call :)

Cheers,

Michael

comment:6 Changed 12 years ago by jason

I'd rather try doing it all at once, since once I'm sifting through the changes in #4267, it'll be easiest just to break it up all at once. I'll try to get this done before the Joint Meetings (hopefully way before).

comment:7 follow-up: Changed 12 years ago by jason

(when I say "all at once", I mean "breaking up #4267 into functional tickets" instead of trying to just pull out one change and then redo #4267).

Likely, #4267 will end up as several tickets:

  1. Make all the existing javascript code spkgs
  2. Various jquery-related cleanups of the javascript code
  3. Add TinyMCE as an (optional?) spkg
  4. Make the shift-click work (in-place wysiwyg editing).

comment:8 follow-up: Changed 12 years ago by jason

#4674 is also a ticket about updating jsmath (but also includes one other thing).

comment:9 in reply to: ↑ 8 Changed 12 years ago by mabshoff

Replying to jason:

#4674 is also a ticket about updating jsmath (but also includes one other thing).

I agree, so I am closing this as a dupe of #4674.

Cheers,

Michael

comment:10 Changed 12 years ago by mabshoff

  • Milestone changed from sage-3.2.2 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from new to closed

comment:11 in reply to: ↑ 7 Changed 12 years ago by mabshoff

Replying to jason:

(when I say "all at once", I mean "breaking up #4267 into functional tickets" instead of trying to just pull out one change and then redo #4267).

Likely, #4267 will end up as several tickets:

  1. Make all the existing javascript code spkgs
  2. Various jquery-related cleanups of the javascript code
  3. Add TinyMCE as an (optional?) spkg
  4. Make the shift-click work (in-place wysiwyg editing).

I would much rather have individual tickers:

  • move jsmath to its own spkg (#4674)
  • move jquery to its own spkg and remove both in tree copies (#3767)
  • cleanups of jquery code
  • TinyMCE
  • in place wysiwyg editing

in exactly that order. Feel free to open three tickets (since we already have the jsmath and the jquery one) and then nuke #4267 and #4184 since both of them are a mess.

Doing multiple related, but independent tasks always leads to giant screw ups like #4276 where one small issue with one aspect of the ticket leads to the whole ticket going stale.

Cheers,

Michael

Note: See TracTickets for help on using tickets.